Commit a02ad67e authored by Brent Dorsey's avatar Brent Dorsey

updating pull request with suggested changes

inserting space between package and verion in requirements sections
removing unused packages from test.requires
refactored grpcio package version requirement to use Jinja templating
inserted  into .gitignore to exclude Intellij IDEA project module definition files
parent 1a4554db
......@@ -11,3 +11,4 @@ __pycache__
# Editor files
*.swp
.idea
*.iml
......@@ -20,29 +20,22 @@ requirements:
- pip
run:
- python
- google-api-core>=1.6.0,<2.0.0dev
- grpcio>=1.8.2
- googleapis-common-protos>=1.5.3,!=1.5.4,<2.0dev
- protobuf>=3.4.0
- google-auth>=0.4.0,<2.0dev
- requests>=2.18.0,<3.0.0dev
- setuptools>=34.0.0
- six>=1.10.0
- google-api-core >=1.6.0,<2.0.0dev
- grpcio >=1.8.2
- googleapis-common-protos >=1.5.3,!=1.5.4,<2.0dev
- protobuf >=3.4.0
- google-auth >=0.4.0,<2.0dev
- requests >=2.18.0,<3.0.0dev
- setuptools >=34.0.0
- six >=1.10.0
- pytz
- futures>=3.0.5
- futures >=3.0.5
test:
imports:
- google.cloud
- google.cloud.container_v1
- google.cloud.container_v1.proto
requires:
- coverage
- docutils
- flake8
- mock
- pytest
- pytest-cov
about:
home: https://github.com/googleapis/google-cloud-python/tree/master/container
......
......@@ -20,9 +20,9 @@ requirements:
- pip
run:
- python
- grpcio>=0.2.2 # must equal grpcio-gcp version
- grpcio >={{ version }}
- grpcio-tools
- protobuf>=3.6.1
- protobuf >=3.6.1
test:
imports:
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment