Commit 095d06a0 authored by Julien Cabieces's avatar Julien Cabieces

DOC: Update QGIS compatibility table

parent 59a9d2d6
QGIS interface
==============
OTB Applications are fully integrated in QGIS since QGIS 3.8.
You can configure OTB for QGIS according to the:
OTB Applications are fully integrated in QGIS since QGIS 3.8.
You can configure OTB for QGIS according to the:
- `QGIS Provider documentation for latest LTR <https://docs.qgis.org/latest/en/docs/user_manual/processing/3rdParty.html>`_.
- `QGIS Provider documentation <https://docs.qgis.org/testing/en/docs/user_manual/processing/3rdParty.html>`_.
......@@ -16,37 +16,41 @@ for the binary packages of OTB 7.1 and above. In this case QGIS 3.14 or more sho
The table below summarizes which version of OTB can be used with which version of QGIS.
+---------------+-----------------+--------------------+
| | QGIS 3.8 - 3.12 | QGIS 3.14 and more |
+---------------+-----------------+--------------------+
| OTB 6.6.1 | Compatible | Compatible |
+---------------+-----------------+--------------------+
| OTB 7.0.0 | Compatible | Compatible |
+---------------+-----------------+--------------------+
| OTB 7.1.0 | Not Compatible | Compatible |
+---------------+-----------------+--------------------+
+---------------+-----------------+-----------------+-----------------+
| | QGIS 3.8 - 3.12 | QGIS 3.14 | QGIS 3.16 |
+---------------+-----------------+-----------------+-----------------+
| OTB 6.6.1 | Compatible | Compatible | Compatible |
+---------------+-----------------+-----------------+-----------------+
| OTB 7.0.0 | Compatible | Compatible | Compatible |
+---------------+-----------------+-----------------+-----------------+
| OTB 7.1.0 | Not Compatible | Compatible | Compatible |
+---------------+-----------------+-----------------+-----------------+
| OTB 7.2.0 | Not Compatible | Compatible | Compatible |
+---------------+-----------------+-----------------+-----------------+
| OTB 8.0.0 | Not Compatible | Not Compatible | Compatible |
+---------------+-----------------+-----------------+-----------------+
Use OTB in old QGIS version (3.6 and less)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
.. warning:: Please consider upgrading your QGIS version.
Since QGIS 3.8 and with 3.10 LTR version, the configuration of OTB Application is
Since QGIS 3.8 and with 3.10 LTR version, the configuration of OTB Application is
directly done in QGIS Provider (see above).
If you use older version of QGIS (from 3.2 to 3.6), you need to install an
additional plugin in order to use OTB applications. This plugin is available
`here <https://gitlab.orfeo-toolbox.org/orfeotoolbox/qgis-otb-plugin>`_
If you use older version of QGIS (from 3.2 to 3.6), you need to install an
additional plugin in order to use OTB applications. This plugin is available
`here <https://gitlab.orfeo-toolbox.org/orfeotoolbox/qgis-otb-plugin>`_
with specific installation instructions.
Troubleshooting
^^^^^^^^^^^^^^^
As of QGIS 3.8 the OTB plugin is in the core. It might get messy if you
have a previously installed plugin. Try to remove the old plugin before
As of QGIS 3.8 the OTB plugin is in the core. It might get messy if you
have a previously installed plugin. Try to remove the old plugin before
launching QGIS.
Issue tracking
^^^^^^^^^^^^^^
If you encounter issues with integration of OTB application into QGIS,
If you encounter issues with integration of OTB application into QGIS,
please `fill an issue <https://gitlab.orfeo-toolbox.org/orfeotoolbox/otb/-/issues/new?issue[assignee_id]=&issue[milestone_id]=>`_ into the OTB issue tracker with `qgis` label.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment