Commit b4c55921 authored by Julien Osman's avatar Julien Osman
Browse files

Merge branch 'update-python-message' into 'release-8.0'

Update the warning message that tells the required version of Python is 3.8

See merge request !909
parents bef386fd 74e2f7ea
Pipeline #10466 passed with stages
in 103 minutes and 10 seconds
......@@ -29,8 +29,8 @@ python_version_check() {
python_check_failed() {
printf %s\\n "*****Error occurred during installation******"
printf %s\\n "OTB python bindings normally require python 3.8 (or 3.7 for windows users) but current \
detected python version is $python_version"
printf %s\\n "OTB python bindings normally require python 3.8 on Linux and MacOS and 3.7 on windows, \
but current detected python version is $python_version"
printf %s\\n "If you have python 3.8 (or 3.7 for win users) installed in your system you should \
set OTB_PYTHON_EXE and re-run this installation script."
printf %s\\n "eg: OTB_PYTHON_EXE=/path/to/python3 ./OTB-X.Y-Linux64.run"
......@@ -61,15 +61,15 @@ python_version_check
if [ ! $CUSTOM_PYTHON ]
then
if [ ! "$python_major_version" -eq 3 ] && [ ! "$python_minor_version" -eq 5 ]
if [ ! "$python_major_version" -eq 3 ] && [ ! "$python_minor_version" -eq 8 ]
then
python_check_failed
fi
else # case where user provides an OTB_PYTHON_EXE
if [ ! "$python_major_version" -eq 3 ] || [ ! "$python_minor_version" -eq 5 ]
if [ ! "$python_major_version" -eq 3 ] || [ ! "$python_minor_version" -eq 8 ]
then
printf %s\\n "*****Warning******"
printf %s\\n "OTB python bindings normally require python3.5."
printf %s\\n "OTB python bindings normally require python3.8 on Linux and MacOS and 3.7 on Microsoft Windows."
printf %s\\n "The version of OTB_PYTHON_EXE ($OTB_PYTHON_EXE) is \
$python_version."
printf %s\\n "This case is undefined unless you are sure the packages were \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment