Commit 553a6330 authored by Rashad Kanavath's avatar Rashad Kanavath

DOC: Cookbook: update install notes for enabling python bindings

parent f7ffca96
......@@ -49,6 +49,18 @@ The applications can be launched from the Mapla launcher. If you want to
use the otbcli and otbgui launchers, you can initialize your environment
with ``source otbenv.profile``.
Python bindings
---------------
Starting from OTB 5.8.0, OTB python bindings are distributed with binary package.
currently only Python 2.x is supported. If no compatible python is found, installation
notify you about it. If everything works fine, you will be given information about
using python bindings.
You must have python numpy bindings installed in your system. you can install it locally
without admin rights with "pip --user install numpy". This is to give users to choose
their own existing python installation rather than distributing one in OTB package
Notes:
- You must use monteverdi and mapla through ``mapla.sh`` and ``monteverdi.sh`` helper scripts in extracted directory.
......
......@@ -25,6 +25,17 @@ Contents of OTB-|release|-Darwin64 is briefly listed below:
- ``share`` : A folder containing common resources and copyright
mentions.
Python bindings
---------------
Starting from OTB 5.8.0, OTB python bindings are distributed with binary package.
currently only Python 2.x is supported. If no compatible python is found, installation
notify you about it. If everything works fine, you will be given information about
using python bindings.
You must have python numpy bindings installed in your system. you can install it locally
without admin rights with "pip --user install numpy". This is to give users to choose
their own existing python installation rather than distributing one in OTB package
Notes:
- If you want to use the otbcli and otbgui launchers, you must access
......
......@@ -22,6 +22,17 @@ The applications can be launched from the Mapla launcher. If you want to
use the otbcli and otbgui launchers, you can initialize a command prompt
with ``otbenv.bat``.
Python bindings
---------------
Starting from OTB 5.8.0, OTB python bindings are distributed with binary package.
currently only Python 2.x is supported. If no compatible python is found, installation
notify you about it. If everything works fine, you will be given information about
using python bindings.
You must have python numpy bindings installed in your system. you can install it locally
without admin rights with "pip --user install numpy". This is to give users to choose
their own existing python installation rather than distributing one in OTB package
Notes:
~~~~~~
- You must have "Visual C++ Redistributable for Visual Studio 2015" installed for using this package.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment