Commit f27ae0b8 authored by Antoine Regimbeau's avatar Antoine Regimbeau

Merge branch 'cmake_undefined_var' into 'develop'

Undefined variable in cmake

See merge request !562
parents 6a977ba7 78fdff0b
Pipeline #2351 passed with stages
in 8 minutes and 3 seconds
...@@ -105,7 +105,7 @@ set ( Python_ADDITIONAL_VERSIONS "3;2" ) ...@@ -105,7 +105,7 @@ set ( Python_ADDITIONAL_VERSIONS "3;2" )
set ( PythonInterp_FIND_REQUIRED ${OTB_WRAP_PYTHON} ) set ( PythonInterp_FIND_REQUIRED ${OTB_WRAP_PYTHON} )
set ( PythonLibs_FIND_REQUIRED ${OTB_WRAP_PYTHON} ) set ( PythonLibs_FIND_REQUIRED ${OTB_WRAP_PYTHON} )
find_package( PythonInterp ) find_package( PythonInterp )
if ( OTB_WRAP_PYTHON AND ( ${PYTHON_VERSION_MAJOR} EQUAL 2 ) ) if ( OTB_WRAP_PYTHON AND ( "x${PYTHON_VERSION_MAJOR}" STREQUAL "x2" ) )
message (WARNING "Python3 not found. There is no longer support of \ message (WARNING "Python3 not found. There is no longer support of \
wrapping in python2 in OTB, but it can still be used.") wrapping in python2 in OTB, but it can still be used.")
endif() endif()
......
...@@ -385,7 +385,7 @@ set ( Python_ADDITIONAL_VERSIONS "3;2" ) ...@@ -385,7 +385,7 @@ set ( Python_ADDITIONAL_VERSIONS "3;2" )
set ( PythonInterp_FIND_REQUIRED ${OTB_WRAP_PYTHON} ) set ( PythonInterp_FIND_REQUIRED ${OTB_WRAP_PYTHON} )
set ( PythonLibs_FIND_REQUIRED ${OTB_WRAP_PYTHON} ) set ( PythonLibs_FIND_REQUIRED ${OTB_WRAP_PYTHON} )
find_package( PythonInterp ) find_package( PythonInterp )
if ( OTB_WRAP_PYTHON AND ( ${PYTHON_VERSION_MAJOR} EQUAL 2 ) ) if ( OTB_WRAP_PYTHON AND ( "x${PYTHON_VERSION_MAJOR}" STREQUAL "x2" ) )
message (WARNING "Python3 not found. There is no longer support of \ message (WARNING "Python3 not found. There is no longer support of \
wrapping in python2 in OTB, but it can still be used.") wrapping in python2 in OTB, but it can still be used.")
endif() endif()
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment